Windows phone users....

Status
Not open for further replies.

123tokambio

Village Sponsor
#7
They have problems with their servers. Bado.
I had installed mine but unfortunately I chose to get fast updates....i tell you its buggy it discharges the battery within 5-6 hrs of minimal use (due to everything running in the background and a non-fuctional data switch). Ended up reverting to 8. Now Av chosen slow...awaiting the service to resume.
 

EngineerLMG

Village Sponsor
#10
I had installed mine but unfortunately I chose to get fast updates....i tell you its buggy it discharges the battery within 5-6 hrs of minimal use (due to everything running in the background and a non-fuctional data switch). Ended up reverting to 8. Now Av chosen slow...awaiting the service to resume.
I'm also on the fast ring, and my phone isn't rolling back to WP8.1 - any help? The WPRecovery Tool throws an error, na sina simu nyingine. Nime-hard reset mara kama 3, to WP10, na bado.
I think I didn't maliza the installation the first time, ndiyo maana. Ama?
 

123tokambio

Village Sponsor
#11
I'm also on the fast ring, and my phone isn't rolling back to WP8.1 - any help? The WPRecovery Tool throws an error, na sina simu nyingine. Nime-hard reset mara kama 3, to WP10, na bado.
I think I didn't maliza the installation the first time, ndiyo maana. Ama?
Am not sure as to why yours is doing so. The same problem has been documented as affecting most Lumia 520. But to most phones the rollback runs smoothly. Does your phone pair with the Software and download the 8.1 version completely? Or at what stage does the error occur?
 
Status
Not open for further replies.

Top